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Manual Conventions

Labels Dispensing system buttons, labels, switches or connections appear
in this text style.

Buttons Fluidmove for Windows (FMW) buttons and dialog boxes appear in
this text style.

Menu Selections All menu selections within FMW appear in this text style.

Commands Fluidmove for DOS (FMDOS) windows, menu selections, and
commands appear in this text style.

Glossary Terms The first occurrence of a glossary term appears italicized and
underlined. The definition of the term occurs in the Glossary.

FILENAME.FM2 Filenames appear in THIS TEXT STYLE.

<typed text> Typed commands, names and values appear in this text
style.

Level 1 Safety Warning. The information following this symbol
cautions you of actions that could cause minor bodily harm to the
user.

WARNING! Level 2 Safety Warning. This symbol will appear in a highlighted text
block. The information in the text block warns you of actions that
could cause serious bodily harm to the user.

Level 1 Machinery and Software Caution. The information following
this symbol cautions you about actions that could cause minor
damage to the machinery or software.

 CAUTION! Level 2 Machinery and Software Caution. This symbol will appear in
a highlighted text block. The information in the text block warns you
about actions that could cause serious damage to the machinery
or software.

?NOTE This symbol appears next to a text block with information you must
know before proceeding, or with helpful information relating to text
that precedes it.

  TIP This symbol appears next to a text block with a timesaving or
technique tip.

   Help This symbol appears next to a text block with instructions for error
recovery.
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1  System Overview

Software Installation

The procedure below instructs you on the installation of the CADImport software onto your
computer, the first step necessary in preparing to use the CADImport system.  The process is
brief and menu-driven.

To install the CADImport software on your system:

1. Load your diskettes into the drive.

> The Welcome box appears.

2. In the Welcome box, click Next.

> A directory box appears.

3. Select the directory on which to install the CADImport system or allow the file to
load to the default directory.

4. Click Next.

Overview of CADImport Features and Options

CADImport works with CAD data from text files generated in a board layout or CAD
program.  The CADImport system allows you to import and reformat this data for
compatibility and use with Fluidmove.  You can use the features available on the Import
CAD File screen to accomplish all necessary reformatting of the CAD data or to access
other data format and viewing screens.

Once the CAD data is imported, the system provides you with an onscreen representation of
the component layout, which you can modify.  There are also options that allow you to
enhance the program for faster throughput.  You can switch to a Dot View screen, which
enables you to modify the dispensing path.  The Step and Repeat Boards feature is an option
that sets up multiple boards to be dispensed with the same pattern.

The Component Library assists you in matching the imported components from your
original file with components predefined by the system.
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The Import CAD File Box

The Import CAD File dialog box is the main screen used for setting data conversion
parameters and selecting from a variety of options.  All options on this screen are discussed
in this section.

Figure 1-1   Import CAD File Box

You can use this dialogue box to:
• Choose a file to read (using the Get CAD File button)
• Choose XY coordinate units (using the XY Units option)
• Specify the data format  as Delimited or Fixed Column (using the Data Format

drop-down menu)
• Assign data types to columns (using the Set Column As menu)
• Mark specific rows as comments or fiducials (using the Set Row As menu)
• Apply a template to a CAD file after the file has been imported (using the Get Template

button) (Get Template automatically assigns predetermined XY Units, Column
Designations and Data Format options)

• Create a template by importing a CAD file and assigning attributes (using the Save
Template button)

• Select from the formatting options related to each data format (using the Format Options
button)

• Import data from the file (using the Import CAD Data button)
• Match the CAD component data with predefined components (mapping library

components; described later in this section)
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Selecting the File to be Read:

To import the desired CAD file, you must display the Import CAD File box (by selecting
Import CAD File from the File menu in the Programming Window in Fluidmove).  You then click
Get CAD File, which brings up a directory of files from which you can select.  Once you open the
file, the CAD data appears in the window in columns of ASCII text.  You can edit and
modify the parameters of this data.

Specifying the Data Format Within Columns:

The Data Format drop-down menu allows you to format the columns in which the CAD data is
presented.  CADImport supports two data formats:  Delimited Column or Fixed.  If you are
designing your own program to generate CAD files, or if you are using an application that
allows you to define the data format, we recommend that you use the Delimited Column
format.  Definitions and guidelines for both formats are listed below.

Delimited column format files:

Delimiters separate columns of data. (See Data Format Options for delimiter types.)
• The file must contain a consistent number of data items per line with no missing

data, separated by a comma, space or other character (the delimiter)
• Data items may occur in any sequence
• There is no restriction on the position and length of data items

Fixed format files:

CADImport automatically sets the column headings to predefined data types in a set order.
You use Data Format Options to set the start and end column for each data type.

• Files may contain missing data or an inconsistent number of data items per line
• Data items may occur in any sequence
• Data items must occur at a fixed position in each row

Complete instructions and examples for both column formats, including the preset column
headings for Fixed Format files, appear in Section 3 – Importing and Formatting CAD Data.
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Assigning Data Types

Once you have defined the format in which the data is arranged, you must use the Set Column
As menu to assign a type to each column of data.  A typical CAD file contains the following
information:

Table 1-1   Typical Data Types

Typical Data Types

Designator A unique label to define each specified location on the
board within CADImport

X Location, Y Location The location of the component on the board

Component The type of component

Rotation Orientation of the component on the board (in degrees)

Please note that CADImport will not import your CAD data file if you do not set a
designator.  You can choose a blank column for a designator if one is not indicated.
Additionally, if you do not set the rotation column or do not indicate the degree of rotation,
the system will default to 0º for all components in your file.

The optional data types can appear in any sequence in a CAD file.  For a more complete
description of the XY location in relation to the board and components, see “The Coordinate
System” in Section 2 – Working with CAD Data Files.

The level is a required data type if you are importing information from a CAD file that
contains data on both sides of the board.  For more information on the level format and
selection, see “Options That Apply to Both Data Formats” in Section 3 – Importing and
Formatting CAD Data.

Table 1-2   Optional Data Types

Optional Data Types

Level A flag to indicate that the component is on the top or bottom level of
the workpiece (for files with components on both levels)

None CADImport ignores the selected data column.  Use this option to skip
a column of data or to deselect a previously assigned column.

Part Number The component manufacturer’s part number (for internal reference)



System Overview 1-5

Setting Rows as Fiducial Locations or Comments

Some files may contain rows for comments and fiducial locations.  In these cases, you can
use the Set Row As option in the Import CAD File menu to mark selected rows as fiducials or
comments.  See “To mark a row as a comment or fiducial location” in Section 3 – Importing
and Formatting CAD Data for more information. You can also add fiducials directly after
importing data at the Dot Layout screen. When you try to save the data as a .FMC file, you
will be prompted to add fiducials if no fiducials are present. To add fiducials, click on Edit
and select Add Fiducials.

Specifying the XY Units

When you click on Import CAD Data, the data from the original CAD file is imported in the same
unit format in which it was created.  The XY Units drop-down box allows you to change the
units in which the imported CAD data is presented.  Possible units in CADImport 1.5 are
µm, mm, cm, mil, and inches.

Templates

To avoid re-assigning data attributes to similar CAD files, you can save attributes to a
template file. To do so, import the CAD file, assign data attributes, including those from the
Data Format Options screen, and click on the Save Templates file.  To use a template,
import a CAD file which has identical or similar attributes matching one of your saved
templates.  Then click on Get Template and choose one of the tpl files.  Data attributes will
automatically be assigned to your data, thus avoiding repetitive action of setting up your
data.

Templates save the following information to a *.tpl file:

• Column designations

• Unit Type

• Data Format Options for Column format e.g. Delimiters including ''Other"

• Data Format Options for Fixed format e.g. starting and ending data columns

• Other Data Format Options  Level selection, Level format, Origin offset, Ignore
problem lines option)

Templates do not save the following information:

• Lines which are comments

• Fiducials



1-6 System Overview

Importing the CAD Data

After you have set the necessary options in the Import CAD File menu, click on Import CAD Data.
CADImport will read the file and issue warnings if import options have not been set
properly, or if there are errors in the file. Then you will see the component list and the
graphical view of the board on your screen.

The File Conversion Process:

Once you have pressed the Import CAD Data button, CADImport performs the following tasks:

1. CADImport makes an initial pass to verify that the data types in every data line are
valid.  When an error is detected CADImport stops and report the error type and
the row number where the error occurred.  If the; Ignore All Problem Lines option
(under Data Format Options) is checked, CADImport will skip any lines with errors.

2. Once the file has been successfully read, CADImport builds its internal component
list from the data.  The component name and attributes (location, rotation, etc.) are
stored in the order in which they are read from the file.

3. The component location is always stored internally in mils.  However, you can set
the XY Units option (in the Import CAD File dialog box) to determine the conversion
units to be used for the coordinates in the raw data file.  For example, if the units
in the raw file are millimeters (mm), you should set the XY Units option to mm, so
CADImport can perform the calculations necessary to transform the millimeter
coordinates into mils.

4. While building the list, CADImport attempts to match each component with one
stored in the internal Component Library.  CADImport refers to the component
name to create the match.  Therefore, a component named C1206 will be matched
with (assigned to) the library component C1206.  However, a component named
CAP-1206 would remain unassigned if it did not match a library component name.
You can assign unmatched components using the Edit menu functions discussed in
Section 4 – Menu and Screen Configurations.
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The Component View Screen

After you click the Import CAD Data button, the Component View screen appears.  This screen
shows a graphic representation of the board and components.  The graphic is an
approximation only; the components and patterns displayed onscreen are 5% larger than
actual size.  The data origin is marked by a +.  At the bottom, the status line appears,
indicating the number of components and the current cursor location.

The left side of the screen displays a component list describing the attributes of each
component.  The toolbar includes the Board Orientation Group and View Group buttons.
The component list and toolbar buttons are described in detail in the following pages.

Figure 1-2   Component View Screen

Board Orientation Group buttons

View Group buttons

Cursor Location

Component List Status Line Data Origin
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CADImport defines the minimum and maximum values in the Component View Screen
based on the coordinate values in the component list.  If you place the cursor at each corner
of the Component View screen, the minimum and maximum values of the imported CAD
data appear in the cursor location.

Components that have been assigned (mapped) to library components are shown with
accurate sizes, shapes and dispense locations.  Unmapped components are displayed as gray
dots.  Component mapping is described at the end of this section and under the Edit menu
options in Section 4 – Screen and Menu Configurations.

Component List

Each line in the Component List contains the component Designator (a label for each
uniquely defined location on the board), the X and Y Location coordinates (in mils) and the
associated data types (designator, rotation, component name, part number).  CADImport
attempts to map as many components to library components as possible during the import
process.  Unmapped component names are displayed in red.  You can manually map these
components by following the instructions “To format the CAD data” in Section 3 –
Importing and Formatting CAD Data.  For further information on component mapping and
the component library, see “Mapping CAD File Components to Library Components” (later
in this section), “Component Library” in Section 2 – Working with CAD Data Files, and the
Component Library feature of the Tools menu in Section 4 – Menu and Screen
Configurations.



System Overview 1-9

Status Line

The status line at the bottom of the CADImport window (in either Component View or Dot
View) shows the cursor location displayed in mils.  The Select Indicator shows the number
of components currently selected, the total number in the Component List and how many
components are currently unassigned.  Also shown is the View Type (Component View or
Dot View) and Dispense Mode (Adhesive or Solder Paste), the zoom factor, and the board
rotation angle.  You can set these parameters by using the View menu and Tools menu
options described in Section 4 – Menu and Screen Configurations.

In the example below, 245 components were read from the original CAD data file. Of these,
191 remain unassigned because the component names did not match any of the names in the
component library. To learn more about manually assigning these components, see
“Mapping CAD File Components to Library Components” at the end of this section.

Figure 1-3   Status Line

X,Y Cursor
Position

Selected
Indicator

View Type and
Dispense Mode

Zoom Factor

Rotation
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Toolbar Buttons

The first three buttons in the toolbar provide the new file, open file, and save file
commands.  The last two allow you to print and access CADImport Help.  The Board
Orientation Group (listed below) allows you to rotate or mirror the board position.  The
View Group allows you to switch to the Dot View screen and to optimize the dot path.  All
of these functions are described in the following pages.

Board Orientation Group: X-axis mirror

Y-axis mirror

Board rotation

View Group: Component View Screen

Dot View Screen

Optimize Path

Figure 1-4   Toolbar Buttons

The Board Orientation Group buttons are enabled only when you are in Component View
mode. These buttons allow you to change the orientation of the board.  Clicking the X or Y-
axis mirror buttons changes the X or Y coordinate sign.  The use of the mirror and rotation
buttons is illustrated below.

Figure 1-5   Mirroring and Rotating the Board

Y

X

Y-mirrorboth X- and
Y- mirror

No mirrorX-mirror
Y

X

rotate 270ºrotate 180º

No rotationrotate 90º
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For example, if you wish to dispense on the back side of the board you might need to mirror
the X coordinates as well as rotate the board to get the correct orientation.

Figure 1-6   Mirroring for Dispensing on Backside of Board

BACK mirrored in X and rotated 90°

BACK mirrored in X-axisBACK
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Dot View Screen

When you click on the Dot View button  CADImport displays the dot pattern.  The number
of dots used for each component depends on the component type and the dispense mode
(Adhesive or Solder Paste).  Unassigned components are displayed as a single dot.  The total
number of dispense dots is displayed on the Status line.

Figure 1-7   Dot View Screen

Dots are displayed in red with a black line indicating the current dispense path.  Initially this
path follows the order of the dots in the raw CAD file, but you can shorten the path for
faster throughput by clicking the Optimize Path button or on Tools; Optimize Path).  The Component View
button allows you to switch back to Component View mode.  For more information, see
“Optimizing the Path” in Section 2 – Working with CAD Data Files.

Dot List

Each line in the Dot List contains the XY location in mils and attributes (designator, dot
type, component name, part number).  Unassigned components are listed in red and
displayed as a single dot on the Dot View screen.

Dot List Number of Dots Dot View Window
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Mapping CAD File Components to Library Components

Mapping allows you to relate each imported component to a corresponding library
component.  Each library component has an associated dispensing pattern.

CADImport enables you to select a group of similar components by any combination of
name, part number, designator or individual selection.  The selected group can then be
mapped to one of the library components.

Figure 1-8   Component Select By Names Box
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Figure 1-9   Library Component Selection Box

Unmapped components are highlighted on the screen and reported on the status line.  Any
unmapped components are omitted from the final Fluidmove file unless you manually map
them to library components.  Component mapping procedures are provided in
Section 3 –Importing and Formatting CAD Data.
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Step and Repeat Boards

The Step and Repeat Boards feature is optional.  It allows you to use a single panel to lay
out multiple boards to be printed with the same dispensing pattern.  You define the number
and layout of boards on the panel by making entries in the Boards (Rows x Cols) boxes.  You then
set the parameters for the dispensing pattern origins and board dimensions for each board.

When you have set all of the parameters and clicked OK, CADImport creates multiple copies
of the components and pattern used on the first board to produce the total number of boards
you defined.  CADImport then generates a new Component List to include all of these
component sets.  Further information on this feature appears in Section 3 – Importing and
Formatting CAD Data.

Figure 1-10  Step and Repeat Board Box
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2  Working with CAD Data Files

This chapter provides a general overview of the process for creating a Fluidmove file from
an existing CAD file.  This chapter also describes the CADImport program interface.  For
the entire data import procedure, refer to Section 3 – Importing and Formatting CAD Data.

More detailed descriptions of all the options are contained in Section 4 – Menu and Screen
Configurations.

Overview of CAD Data Import to Fluidmove

Figure 2-1   CADImport Process Flow

Import CAD file

Map CAD file components to
library components

Step and Repeat Boards
(optional)

Optimize path for most efficient
production

Generate Fluidmove files

Original CAD file
.TXT file

Component library file
.LIB file

 .FMW .AVW
and .FMC files

 .JOB file
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 About CAD Files

The first and most important step in using CADImport is reading the CAD file data from the
.ASC or .TXT file (see “File Types” below).  While CADImport offers some flexibility in
formatting, it is important to begin with a file that is compatible with CADImport’s data
format options.  Starting with a correctly formatted CAD file makes using CADImport quick
and easy.

File Types

CADImport accommodates three types of files, which are usually used in this order during
the import process.

Table 2-1   CADImport File Types

File type Extension Description How created How used

CAD files *.ASC or
*.TXT

ASCII files containing
component locations

and information

Board layout
program or CAD

program

Imported at the
beginning  of the
CADImport job

CADImport job
file *.JOB

Contains job
information specially
formatted for use in

CADImport.

CADImport -
Save; Save As

Saved during the
creation of the
CADImport job

Fluidmove files
*.FMW
*.AVW
*.FMC

Specially formatted
for the Fluidmove

program.

(.FMC files for FmNT
version 4.0 or later)

CADImport -
Save As

Fluidmove File

Imported into
Fluidmove
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 The Coordinate System

The CADImport program uses the following conventions for its coordinate system:
• Coordinates are stored internally stored as mils. You must manually specify the

coordinate unit type in the XY Units box in the Import CAD File dialogue box.
• CADImport uses a standard Cartesian coordinate system.
• The origin (0,0) is indicated by a +.
• Components may be located in any of the four quadrants of the Component View

and Dot View screens: +x+y, -x+y, -x-y, +x-y.
• CADImport automatically sets up the minimum and maximum XY values based on

the location coordinates in the CAD data file. The size and shape of the view
window are determined by these values as shown below.

  

  

  

  

  

  

  

  

Figure 2-2   Coordinate System

Data Origin

X min, Y min

X max, Y max

+X

+Y

+
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Component Library

The CADImport Component Library contains approximately 300 SMT components
classified into 13 Component Types. Appendix A lists the Component Types and their
individual components. The component library is provided in the Asymtek.lib file.
CADImport refers to this file to assign components from the original CAD data file to
library components.

Each library component has a unique name and a specific set of properties.  These include
the dispense dot locations for adhesive and solder paste mode and the landpattern geometry,
size and spacing information utilized for each component.

In Component View mode, CADImport displays the component body in black, the pins in
gray, and dispense dots in red. In Dot View mode, only the dot locations are shown.

In this dialogue box, you can:

• See a graphic of the component and set the Dispense Mode to dispense dots in either
Adhesive or Solder paste

• Edit the dispense dot locations, or add and delete dots
• Edit the component properties (landpattern width and height, pin length and width)
• Save modifications to an existing component or create a new component

Figure 2-3   Component Library Box
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Editing Dot Locations

The Dot Locations List displays the XY dot locations (in mm units) for the selected component.
The window provides a graphic representation of the currently selected component with
dispense dots.  The dot configuration shown for the component (number and locations) is
determined by the dispense mode you select: (Adhesive or Solder Paste).   You can select a
dot from the list or by clicking on it in the window, then enter new XY values to change the
dot location.

You can also insert a new dot before the current selection in the Dot Locations list or delete a
dot from the list.  Instructions for each of these procedures appear in Section 3 –Importing
and Formatting CAD Data.

Editing Component Properties

Click on the Component Type arrow to see a list of the component categories included in
the CADImport Component Library.  When you select a component type from the list, all
components of that type appear in the Component Name list.  You can select a specific
component by clicking on its name in this list.  When you change the component type or
component name, the screen is updated to show the selected component.

You can edit the various parameters of the selected components by clicking on Properties in
the Component Library box (Figure 2-3) to open the Component Properties box, shown
below.  Once you have made changes, you can replace the original component by saving it
under its original name, or you can create a new component name for the modified
component.  Examples of these procedures and a detailed illustration of the component
properties as they relate to an actual component are provided in Section 3 – Importing and
Formatting CAD Data.

Figure 2-4   Component Properties Box
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Step and Repeat Boards

The step and Repeat Boards feature is an optional step in the CAD import process.  It allows
you to use a single panel to lay out multiple boards to be printed with the same pattern.  You
define the number and layout of boards on the panel by entering the desired numbers in the
Boards (Rows x Columns) boxes.

Figure 2-5   Step and Repeat Boards Box

By default, CADImport uses the minimum and maximum location values from the
Component List to calculate the step distances and sets up the panel as an array of
equally-spaced boards.

The Step and Repeat Boards dialogue box enables you to set all parameters necessary for
arranging the boards, including the origin coordinates of the dispensing pattern on each
(X Start, Y Start).

When you have set all of the parameters and clicked OK, CADImport creates multiple sets of
the components on the first board to produce the total number of boards defined in the Boards
(Rows x Cols) boxes.  CADImport then generates a new Component List to include all of these
component sets.

For complete instructions on using all features available on this screen, refer to “Laying Out
Step and Repeat Boards” in Section 3 – Importing and Formatting CAD Data.
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Optimizing the Path

Initially, the dispense path is generated based on the sequence of the dots as they occur in
the original file. More efficient movement is produced by optimization, which shortens the
dispense path using the nearest neighbor method. This is an essential step for efficient
production.

The Optimize Path command reorders the dots to minimize the path length for more efficient
production.

    

Figure 2-6   Optimizing the Dispensing Path

This option is only available in Dot View mode.

The optimizing process begins when you click on Optimize. The dots are reordered in the Dot
List using the nearest neighbor method to shorten the path. This does not affect the order of
the components in the Component List. When the optimization is complete, CADImport
reports the new path length and difference in path distance as shown above.

Path After OptimizationPath Before Optimization
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Any editing changes such as re-assigning components, changing their location, or changing
the board orientation (using mirror and rotate) will cause re-generation of the Dot List, so
you will need to re-optimize.

If you are setting up a panel with multiple boards, you should first use the View; Step and Repeat
Boards option to set up the panel, then use Optimize Path to shorten the path.

Generating a Fluidmove File

The mapped components and optimized path are formatted into Fluidmove program files
(.FMW, .FMC and .AVW files).
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3   Importing and Formatting CAD Data

The procedure for importing CAD files into Fluidmove is a two-step process.  You must first
format the raw CAD data within the CADImport system, then import the data into
Fluidmove.  Both procedures are described in detail below.

To format the CAD data:

1. In the initial CADImport screen, select the File menu.

2. From the File menu, select Import CAD File.

> The Import CAD File dialogue box appears.  (See Figure 3-1 below.)

Figure 3-1   Import CAD File Dialog Box

3. Click Get CAD File.

> A directory box appears.

4. Browse through the directory to locate the desired CAD file, select it, and click
Open.

> The CAD data appears in the window formatted into columns of ASCII
characters separated by the delineator.

5. Click on the Column 1 heading so that the column is highlighted.
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6. In the Set Column As box, select the data type for Column 1.

7. Repeat Steps 5 and 6 for the remaining columns of data.

8. If it is necessary to change the units of measurement of the data, click on the
column heading to highlight the column.

> The unit of measurement should be the same as the one used by the CAD
designer to create the file.

> The unit appearing in the XY Units box when the data initially appears does not
necessarily apply to the data; it is a default unit.

9. In the XY Units box, select the unit of measurement to be applied to the data.

> The data will not change until you perform Step 10.

10. Click Import CAD Data.

> The Component (Adhesive or Solder Paste) View screen appears.  A
Component list appears on the left of the screen, indicating the attributes
associated with each component.  A representation of the board with the
component pattern is shown on the right.  The data origin is marked by a +.
Note that this representation is 5% larger than actual size.

> The Status Line indicates the number of components and the current cursor
location is indicated to the far left in XY coordinates.

Component List Component Window

Figure 3-2   Component View Screen
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11. To change a component type, select View Type under the View menu.

> If the component type is correct, skip to Step 18.

12. From the drop-down menu, select Component.

13. From the Edit menu, choose either Select All (to change the type for all components)
or Select By Names (to change only one type of component).

14. From the Edit menu, choose Edit Selected.

> The Component Properties box appears.

Figure 3-3   Component Properties Box

15. Click Browse.

> The Select Component box appears.

Figure 3-4   Select Component Box
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16. Click on the arrow to the right of Component Type, and scroll through the Component
Type list to select the component type that most closely matches the one you need.

17. Click OK.

> The component type is changed.

18. Select View Type from the View menu.

19. From the drop-down menu, select Dot.

> Alternatively, you can click on the View Dot button.

> You are now provided with a full-screen view of the workpiece, with lines
representing the pattern.  You can select areas on the workpiece to program in
the pattern.  Each area changes color as it is selected.

Figure 3-5   Dot View

20. From the Tools menu, select Optimize Path.

> The Optimize Path box appears.

21. Click Optimize.

22. The system attempts to create the shortest possible path between the dots.
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23. To edit the pattern, double left-click on the dot location in the component list or
right-click on the dot within the pattern (on the right side of the screen).

> If you right-click on a dot, select Edit Selected from the drop-down menu.

> The Dot Properties box appears.  You can now change the dot location, the
order in which it is inserted into the pattern (Insertion Order), and dot type.

Figure 3-6   Dot Properties Box

24. From the File menu, select Save As Fluidmove File.

> The Export Fluidmove File box appears.

25. Select a filename and a directory path, and click Save.

> Both a .AVW and a .FMC file are created when you save.  Both extensions
designate Fluidmove files.

> It is best to also save the file as a .JOB file, which holds the raw CAD data, for
future component or pattern changes.  To do this, select Save As from the File
menu, then enter a filename.  The .JOB extension is applied automatically.

To import the CAD data into Fluidmove:

1. Copy the .AVW and .FMC files onto a floppy disk.

2. Load the floppy disk into the A drive on the dispensing system computer.

3. Copy the .AVW and .FMC files from the floppy disk into the Programs Folder in
the FmNT root directory.

4. In the Main Window, click Teach a Program.

5. In the Programming Window, click on File on the menu bar, and select Open CAD
Import File.

> A dialog box opens in which you can browse the directory and find the .FMC
file you loaded earlier in this procedure.
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6. Locate the desired .FMC file and click Open.

> A message box opens indicating that a board must be loaded for the next step
and asks you if you need to load a board.

7. Place a board at the mouth of the conveyor. Adjust conveyor width, if necessary.

8. Click Yes.

The conveyor will move after your response.

> The board is automatically conveyed into the dispense zone and clamped in
place.

> A Teach Window opens asking you to Teach the Workpiece Origin.

9. Use the Position Controls in the Teach Window to move the dispensing head to the
Workpiece Origin. Center the camera crosshairs over the location.

10. Click Teach.

> The Teach Window closes. A message box opens stating that the CAD Import
process is complete. It also states that if you notice incorrect positioning during
fiducial findings, adjust the “Do Workpiece AT” instruction. And if you notice
incorrect positioning during dot dispensing, adjust the “Do Panel AT”
instruction.

11. In the Programming Window, double click on the Do Panel AT command line.

> A Teach Window opens asking you to Teach Fid 1 Manually.

12. Use the Position Controls in the Teach Window to move the dispensing head to the
location of the first fiducial. Center the camera crosshairs over the location.

13. Click Teach.

> You are asked to Teach Fid 2 Manually.

14. Use the Position Controls in the Teach Window to move the dispensing head to the
location of the second fiducial. Center the camera crosshairs over the location.

15. Click Teach.

16. Click Done.

17. Select Save from the File menu, and name the file.

> Make sure that your filename is different from the one already on the floppy
disk.

> You have now saved the file as a program containing only the workpiece
origin and two fiducials.

18. Select Save from the File menu.
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Formatting the Data into Columns

Figure 3-7   Column Heading Selected

CADImport accommodates two column formats for presenting imported CAD data:
Delimited Column and Fixed Format.  The Data Format drop-down menu allows you to select
the format.  If you are designing your own program to generate CAD files or if you are using
an application that allows you to define the data format, we recommend that you use the
Delimited Column format.  Each format provides specific options, which are described in the
following pages.  Definitions and guidelines for both formats are listed below.

Delimited column format files

Columns of data are separated by delimiters.

• The file must contain a consistent number of data items per line with no missing
data, separated by a comma, space or other character (the delimiter).

• Data items may occur in any sequence.
• There is no restriction on the position and length of data items.

Fixed format files

Each data type starts and ends at a specified character position on the row of data.  You click
Data Format Options , then use the Fixed Format options in the Data Format Options box to set the
starting and ending positions of the columns for each data type.

• Files may contain missing data or an inconsistent number of data items per line.
• Data items may occur in any sequence
• Data items must occur at a fixed position in each row; there are no delimiters.
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Data Format Options

The Data Format Options box appears when you click the Data Format Options button in the Import
CAD File box.

Figure 3-8   Data Format Options Box

The options in this box that you will use depend on your Data Format selection (Delimited
Column or Fixed).  For Delimited Column, you will select Column Delimiters.  For Fixed format
columns, you will set the Start Col and End Col.  These options are described in detail in the
following pages.

The Level Selection, Level Format, Ignore all problem lines and Origin Offset options are applicable to both
Delimited Column and Fixed format data format options.  These features are discussed later
in this section.
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 Delimited Column Format

You can use the Delimited Column format if your file contains a consistent number of data
items per line.  To use this option, you must set the Data Format box to Column in the Import
CAD File dialog box (see Figure 3-7).  You will use the Set Column As option to assign a data
type to each data item (this procedure is described in detail in “To Assign a Data Type to a
Column,” later in this section).  You will then separate the data items with a comma, space
or other character(s).  The column headings can appear in any order.  Unassigned columns
are ignored when the file is read.

When you click Data Format Options, the Data Format Options dialogue box appears (see Figure
3-8), allowing you to set the column delimiters.  Space, Tab, Comma and Semi-colon are all selected
as the default delimiters.  The delimiter(s) you select should correspond to the one(s) to
separate the data in the original CAD file; deselect those that are unnecessary.  Make an
entry in the Other box if you wish to specify a different delimiter from those shown below.
When you have indicated the desired delimiters, click OK.

 

Figure 3-9   Column Delimiters

When you import the data using the Delimited Column format, CADImport scans the entire
data line for each component, extracts data items between delimiters, and assigns data types
according to your selection in the Set Column As box.  In a Delimited Column format, data items
may occur in any sequence and, unlike the Fixed format, there are no restrictions on the
position and length of the data.

You may choose more than one delimiter type.  If you do, all characters of the types you
select will be treated as delimiters when the file is read by CADImport.  In the example
below, both comma and space have been selected as delimiters.

C1, 1000, 1200, 90, C1206
| | |

Designator Ylocation Component
Xlocation Rotation
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For a file with the following data, you should select both the space and comma delimiters,
since both have been used to separate data in this file.

C1  1000,2000  90 C1206
C2   500,150     90 R1206

This data could also occur as:

C1;1000;1200;90;C1206

where semi-colon has been chosen as the only delimiter.

If the data in your original file is separated by a delimiter that is not on the list, such as a
colon, you should enter it in the Other field under Column Delimiters in the Data Format Options
box.  CADImport will use a colon to separate the data items and will read the file correctly.

C1:1000:2000:90:C1206
C2:500:150:90:R1206
etc
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Fixed Format Files

The Fixed data format offers a different way to break up the information within files.  Each
data type occupies a defined position on the line of data and within the file.  Columns of data
items are separated by specific numbers of spaces that you indicate within the Data Format
Options feature instead of by delimiters.

Within the Data Format Options box, define the Start Col and End Col positions for each data
type (under Fixed Format Options).  You must first analyze your data to determine the starting
and ending positions of the columns for each data type.  The Start Col and End Col fields refer to
the character position in the row of data at which each column begins and ends.

In the example below, the designator starts at position 1 and ends at position 3 along the row
of data, since there are three characters in the longest item in the column.  Notice that the
data may fill the space allocated for the three character positions, but may be shorter.  The
next defined column, the Xlocation field, starts at 8 and ends at 11.  The Ylocation starts at 14 and
ends at 17.  Note that several character positions are skipped in between columns of data.
The skipped positions separate the columns.

C1     1000  3000   90    CAP1206

C23    2000  3500    0    RES1206

C3     2500  5600   90    CAP5026

123456789012345678901234567890123

Character Positions on
the Row of Data Fixed Format Options

Portion of Data Format
Options Box

Data Items
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For files with missing data or an inconsistent number of data items per line you must use the
Fixed Format to allow CADImport to extract the data items for each component.  The
example below requires use of the Fixed Format feature.

C1 1000 2000 90 CAP1206

C23 2000 3000 0 X1 RES1206

C3 2500 4000 90 X2 CAP5026

When you import a file and set the Data Format to Fixed Format, the column headings are
automatically set as shown below.

Table 3-1   Preset Fixed Format Column Headings

Column 1 Column 2 Column 3 Column 4 Column 5 Column 6 Column 7

Designator X Location Y Location Rotation Component Part No Level

Unassigned columns are ignored when the file is read.  In the example below, the
Component and Level data types were not assigned to the file.  Therefore, they do not
appear.

C1 1000 2000 90 C1206

C2 1500 3000 90 C1206

C3 2500 3500 180 R5026

Designator Xlocation Ylocation Rotation Part Number

Col 1 - 2 Col  10 - 13 Col 18 - 21 Col 28 - 30 Col 35 - 39

missing data
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In the example below, the Part No and Level data types were not assigned, so you should not
make entries in the Start Col and End Col fields for these data types.  Note that the Designator
contains three characters in the largest item (C23).  Therefore, it occupies positions 1
through 3.  The XLocation occupies four characters, from 8 to 11, and so on.

C1     1000   90    CAP1206  3000

C23    2000    0    RES1206  3500

C3     2500   90    CAP5026  5600

123456789012345678901234567890123

Options That Apply to Both Data Formats

The Level Selection, Level Format, and Ignore all problem lines options in the Data Format box can be
used for both Delimited Column and Fixed format files.  Level Selection and Level Format are used
in conjunction with each other and allow you to define the side of the board from which the
data should be taken when the data file has components on both sides of a board.  Ignore all
problem lines is useful for files with extraneous comments or data that is unrelated to
component data values.  These options are described in detail in the following pages.

Designator

XLocation

YLocation

Rotation

Component
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Setting the Level Format and Level Selection

Level Selection and Level Format should be used when the data file contains components on both
the top and bottom levels of the board.

Since the resulting FMC file should contain components for one level only, CADImport
must read in the data for one level at a time.  Level Selection indicates to CADImport whether
the top or bottom level of components should be read from the original CAD file.

?NOTE You do not need to use these options for CAD data files with components
on only one level.

Since these options apply to both data formats, you must use a separate procedure for each
when setting the level selection and format.  You must define the columns as follows:

Column format files Select the column and choose Level from the Set
Column As option list

Fixed format files Set the Data Format Options: Level Start and End
columns

To set the Level Format and Level Selection:

The Level Selection option acts as a filter when the raw CAD data is imported, only displaying
the components that correspond to the side of the board you have selected.  You must first
use the Level Format option to identify indicators for the top and bottom sides of the board.
You then select the side of the board to be read.  Follow the procedure below.  An example
follows this procedure.

1. Retrieve the data file by clicking on Get CAD Data.

2. When the directory box opens, browse through the directory to locate the desired
CAD file, select it, and click Open.

> The CAD data appears in the window formatted into columns of ASCII
characters separated by the delineator.

3. Click on the column heading for the column that contains the board side
information.

> This column of data contains only two instances of varying data (for example,
TOP and BOT or A and B); these are the level formats (described later).

4. In the Set Column As List, choose Level.

> Either Level (Top) or Level (Bot) is OK at this point in the procedure.

5. Click Data Format Options.

6. Under Level Selection, indicate Top Level or Bottom Level, depending on the side of the
board from which you will be extracting data.
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7. In the Level Format boxes, enter an indicator for each side of the board, based on
those used in the original file.

> The level identifiers can be up to 12 characters long.

> If you are unsure which indicators are used, refer to the column of data that
contains only two instances of varying data, which you selected in Step 3 (for
example, TOP and BOT or A and B); these are the level formats.

8. Click OK.

> The column heading now reflects the board level from which you have
selected components to be read by CADImport.

In this example, rows 1, 2 and 4 are located on the bottom of the board (indicator = BOT).
Rows 3 and 5 are on the top (indicator = TOP).  If you had selected bottom as the Level
Selection in Step 5 of the previous procedure, only those rows of data with the indicator BOT
would be read when the data is imported.

C1 1000 2000 90 C1206 BOT

C2 1500 3000 90 C1206 BOT

P1 1000 2500 0 PLC160 TOP

C3 2500 3500 180 R5026 BOT

P2 3000 5000 0 LC160 TOP
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Activating the Ignore all problem lines option

The Ignore all problem lines option can be used for either Column or Fixed format files that have
numerous comments or extraneous data that is not related to component data values.

Usually when you click Import CAD Data, CADImport scans through each line in the file checking
for errors.  When irregular or missing data is detected, CADImport stops and reports the row
number and error type for each problem.

When you check the Ignore all problem lines option, CADImport ignores any line that can not be
correctly interpreted as data.  CADImport continues reading the file without issuing any
warnings.

1 C1 1000 2000 90 C1206

2 -----------------------------

3 C2 1500 3000 90 C1206

4 -----------------------------

5 C3 2500 3500 180 R5026

6 -----------------------------

In the example above, CADImport would normally report an error on Rows 2, 4, 6, etc.  You
could use Set Row As to mark each of these lines as a Comment, but that approach could prove
time consuming for a large file.  Checking the Ignore all problem lines option allows CADImport
to automatically skip these lines.
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Origin Offsets

Origin Offsets is an X,Y coordinate value applied to each component so that the CAD file is
centered on the screen. Figure 3-10 below is an example of a CAD file without Origin Offset
applied. Notice the location of the pattern. Figure 3-11 shows the same CAD file with Origin
Offset applied. In Figure 3-11, the Origin Offset of (–324,-189), changes the coordinates of
the first component from (324,189) to (0,0),centering the pattern on the screen. You can also
modify the Origin Offset within FMW or FmNT by adjusting the X,Y coordinates of the
“Do Panel” pattern.

Figure 3-10   Origin Offset Not Applied
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Figure 3-11   Origin Offset Applied



Importing and Formatting CAD Data 3-19

Column Data Types

Once you have determined the column format of the imported data, you must assign a data
type to each column.  The Set Column As option allows you to assign data types to each column
of CAD data in a file with a Delimited Column format.

To use this option, Data Format must be set to Column.  This procedure is not necessary for data
in a Fixed Format file, as data types are predefined for this format.

To assign a data type to each column:

1. Click on the column heading you will be defining so that the column is
highlighted.

2. In the Set Column As list, choose the data type.

3. You may now select from the following data types for the remaining columns.

Table 3-2   Available Data Types

Set Column As: Definition:

None CADImport will ignore the selected data column. Use this option to skip
a column of data or to de-select a previously assigned column.

Designator A unique label for that location on the board

X Location, Y Location
The centroid (center point) location of the component (see the
Coordinate System section in the About CAD Files section for more
details.)

Rotation Orientation of the component on the board (0, 90, 180, or 270 degrees)

Component Identifier for the type of component

Part Number (optional) Component manufacturer’s part number for internal reference

Level

A flag to indicate the top or bottom level of the board for files with
components on both levels.

See the Data Format Options dialog Level Selection and Level Format
options for more information on using this flag.
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Rows Marked as Comments or Fiducial Locations

Use the Set Row As option in the CADImport dialog box to mark a particular row as a comment
or fiducial location.  You may use this option in conjunction with both Column and Fixed
format files.

To mark a row as a comment or fiducial location:

1. Click on the row or rows of data you will be marking in the CADImport dialog
box.

> To select a single row click the row number (1, 2, etc.).  For a block of rows,
click the first row number, hold down the shift key and click the last row
number.

2. Choose the row definition from the Set Row As list.

> Refer to the table below for available definitions.

3. Follow Steps 1 and 2 for all remaining rows to be assigned.

Table 3-3   Available Row Definitions

Set Row As: Definition

Data The default setting for all rows.  CADImport reads the row as data.
Data lines are displayed in black.

Comment CADImport ignores comment lines.  Comments are displayed in red.

Fiducial 1, Fiducial2 CADImport marks these lines as FID1 or FID2.

Edit Text

This feature allows you to make editing changes directly to rows of CAD data before you
import it (after you have clicked Get CAD File to retrieve the file).  This option is only available
when you select a row.  A dialog box allows you to view and edit the text in the currently
selected row.  This option is not recommended for files that require extensive changes.  It is
most useful for minor editing.  For files requiring extensive changes, it is advisable to return
to the program in which the original CAD file was created and make corrections in that file.
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In the sample file below the rotation data is missing from row 5.  When CADImport reads
this file, it will issue a warning about missing data in this row.

3 C1 1000 2000 CAP1206 90

4 C23 2000 3000 RES1206 0

5 C3 2500 4000 CAP5026

The quickest way to fix this problem is to select Row 5 and use Edit Text to add the rotation
data.

Changes made by text editing are preserved during the CADImport session and saved in the
*.JOB and *.FMW files you create, but they are not written back to the original CAD file.

missing rotation data
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Component Mapping to CAD Library Components

When a CAD file is imported, some or all of the component names may not match those in
the CADImport Component Library.  These components are marked as unassigned.
Unassigned components are displayed as gray dots on the Component View screen and in
red in the Component List.

In Component View mode, you will typically use the Component Properties box to assign
(map) a group of components to a Component type from the CADImport Component
Library.  You may also use this box to edit the properties for a single component.
Additionally, you may change the properties of individual library components.  These
procedures are explained below.

To map CAD file components to the Component Library:

1. From the View menu, select View Type.

2. Select Component from the drop-down menu.

3. From the Edit menu, choose Select All (for all of the components in your file) or Select
by Names (to select specific components only).

> If you choose Select by Names, enter the component name in the Component field,
and click Select next to the field.  The screen will indicate the number of
components selected for this name.

4. Click OK to return to the Component View screen.

> The selected components will be highlighted in red in the Component List and
displayed as green dots on the graphical view.

5. From the Edit menu, choose Edit Selected.

> The Component Properties box appears (see Figure 3-12).

> If you have selected a single component, you may edit any of the individual
component properties in the box.  Once you have made your entries, click OK.
It is not necessary to continue this procedure to the end for single component
editing.

Editing X Location or Y Location changes the component location on the board.

The Rotation field controls the component orientation on the board.

The Part no field is provided for your internal reference.

> If you have selected more than one component (a group), you may make
entries in the Component and Part no boxes only; the others will be grayed out.
You may then map the group to a predefined component type in the
Component Library.  To do this, go to Step 6.  If necessary, you can change
the properties for the component type during the mapping procedure.  (See
Figure 3-13.)
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Figure 3-12   Component Properties Box; Single Component Selected

6. Click Browse.

> The Select Component box appears. See Figure 3-13.

7. Click the arrow to the right of the Component Type field.

Figure 3-13   Mapping Components to a Library Type
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8. Choose the class of components you wish to view from the Component Type list.

9. Choose a specific component type from the Component Name list.

> Choose the component with properties that most closely match those you need.
You can change the specific component properties later; see “Changing the
Component Properties,” immediately following this procedure.

10. Click OK.

> The Component Properties box reappears.  Your component name appears in
the Component field.

11. Click OK to assign all of the selected components to this library component type.

> The Component View screen reappears.

> All previously unassigned components with the component name you selected
are redrawn as the chosen library component type in the Component View
graphic and are listed in black in the Component List (meaning that their
names are considered valid).

> Notice that the number of unassigned components on the Status Line has been
reduced by the number you have assigned.
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Changing Library Component Properties

You can use the Component Properties box (shown below) to change any of the library
component properties.  Use the following procedure.

To change component properties in the Component Library:

1. Select Component Library from the Tools menu.

> The Component Library box appears.

2. Click Properties.

> The Component Properties box appears.

3. Make any necessary adjustments to the property fields.

> The figure on the following page illustrates the relationship of the component
land pattern values in this dialogue box in relation to the actual component.

> The Dot Type boxes allow you to determine the dot size and dispensing
characteristics such as Valve-On Time, dispense gap, settling time, etc.  You
may enter any value from 1 through 8.  Please refer to the Fluidmove for
Windows NT Installation and User Guide for detailed descriptions on dot
types and their associated parameters.

4. When you are satisfied with your new component parameters, click OK.

> You may now save the modified component as a new component or use the
same name to overwrite the existing component.  Refer to the procedures on
the following pages for instructions on saving modified components.

Figure 3-14   Component Properties Box
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Figure 3-15   Component Properties as They Appear on Actual Component
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Saving Modified Components

Figure 3-16   Save Component Box

The Save Component box allows you to save modifications to the existing component or to
create a new component with these modified properties.  Once you are satisfied with the
changes you have made to a component selected from the Component Library box or the
Properties box, you can save the changes by clicking Save.  Clicking on Cancel will undo all
changes made to the component.

To create a new component (example):

The example below creates a modified version of the BERG1-8 component from the
Connectors component type group to illustrate the procedure.

1. Select Connector from the Component Type list, then select the BERG1-8 Component from
the Component Name list.

2. Change the adhesive dot locations in the Dot Locations list as desired.

> You could alternately click Properties to change other qualities of this component.

3. To save this modified component, type a new name in the Component Type text box
and a new name in the Component Name text box and click OK.
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Deleting Components from the Component Library

Figure 3-17   Delete Component Box

The Delete Component box allows you to remove unwanted components from the
component library.  To access this box, click Delete in the Component Library box.  Use the
Component Type and Component Name lists to select the component you want to delete, then click
OK.  The component will be removed from the library.
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Editing Dot Locations in the Component Library

The Dot Locations list in the Component Library box displays the XY locations (in mm units)
for the selected component.  A graphic representation of the selected component appears to
the right of the box, depicting the location of dispense dots.

If you know the coordinates of the dot you wish to modify, you can place the cursor into an
X or Y location box in the list.  The selected dot will appear in green in the component
picture.  You can then change the coordinates as necessary.

Alternately, you can click on the dot in the picture of the component in the window.  If you
do this, the corresponding row in the dot list will be highlighted.  You can then make
changes to the coordinates.

Figure 3-18   Component Library Box
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Inserting and Deleting Dots

You can add a new dot to the Dot Locations list by inserting it before the currently selected
line.  To do this, click on the appropriate X or Y location box, then click Insert Dot.  An empty
row will appear in the list, allowing you to enter new dot coordinate data.

For example, to insert a new dot between rows 5 and 6, click on row 6 to select it.  Then
click Insert Dot.  The new empty row will appear between rows 5 and 6.  You can now enter the
XY Location for the new dot.

To remove any dot from the list, select the dot by clicking on a coordinate in the Dot
Locations list or double clicking on the graphic depiction of the dot.  Then, click Delete Dot.
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Laying Out Step and Repeat Boards

The Step and Repeat Boards feature allows you to use a single panel to lay out multiple
boards to be printed with the same pattern as your original board.  Once you have indicated
the desired number of boards for a dispensing panel, you can modify the parameters of each.

?NOTE Once you have designated the panel layout and clicked OK,
CADImport generates a new Component List by duplicating the
components on the first board to accommodate the number of
boards you indicated.  Therefore, it is best to make all editing
changes on the original (single) board before using the Step and
Repeat feature.

To design the panel layout and set specifications:

1. Select Step and Repeat Board from the Tools menu in your Component View screen.

> The Step and Repeat Boards screen appears.

Figure 3-19   The Step and Repeat Boards Screen

2. Indicate the desired number of rows of boards (across) in the first Boards (Rows x
Columns) box.

3. Indicate the desired number of columns of boards (down) in the second Boards (Rows
x Columns) box.
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4. Click on New Panel to get a preview of the panel layout you just created.

> The step distance parameters are displayed in the Step Distance (X x Y) boxes.
These dimensions are based on the minimum and maximum location values
from the original board.  The default step distance is the same as the width and
height of the original board.  These settings will change to reflect any changes
you make to the XStart or YStart boxes.

> The value in the XStart box indicates the origin of the pattern on the second
board on the X-Axis (row) in relation to the 0,0 pattern origin of the first
board.

> The value in the YStart box indicates the origin of the pattern on the next board
on the Y-Axis in relation to the 0, 0 pattern origin on the first board. The
boards are equally spaced on the panel.

> These pattern origin distances are approximations only; the area of the board
displayed onscreen is 5% larger than actual size.  Therefore, it is important to
measure the actual pattern origin distances by hand if you need to know the
exact figures for programming purposes.  The distances between the dots in
each pattern are, however, accurate.

5. Specify the unit type to be used for the board size and step distance in the Units box.

> While these coordinates are stored internally in mils, this option allows you to
work with any of the coordinate types.

6. The Board # list indicates the board number, XStart, YStart and Rotation for each board
on the panel.  You can change these settings as well as the board Width and Height.

> If you change these values, click on Save Values to see a preview of the new board
properties in the Panel Layout window.

7. When you are satisfied with the settings, click OK.

> CADImport generates a new Component List by duplicating the components
on the first board to accommodate the number of boards you indicated in the
Boards (Rows x Columns) setting.

> Once the new list has been generated you can use the board orientation buttons
(X mirror, Y mirror, and Rotation) to re-orient the entire new panel as needed.
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4   Menu and Screen Configurations

This section provides a reference of all features and options available on the CADImport
menus.  If you are unable to locate an explanation for a menu option in the other sections of
this manual, refer here for a description and references to other places where the item is
discussed.

The File Menu

  

Figure 4-1   File Menu

The File menu provides all of the basic file operations, such as opening, saving and
importing.  The CADImport system provides various options for accessing and saving your
files.  These options are described in the following pages.

The New Command

This command begins a new CADImport job.  If you are working on another job you will be
prompted to save it before starting a new job.
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The Open Command

  

Figure 4-2   Open Job File

This command opens a previously saved CADImport Job file (*.JOB file).  Enter the name
of the CAD File under File Name in the Open Job File box, (or click Get CAD File in the Import
CAD File box) to locate the file in your directory.  CAD files usually have a .TXT or .ASC
file name extension.  See “File Types” in Section 2 – Working with CAD Data Files for a
complete explanation of each file type.

Figure 4-3   Get CAD File

Your currently selected CAD file appears onscreen in the Import CAD File box.  The
number of lines read from the file appears at the bottom of the screen.  If it does not appear
as you expect, you may need to change the data format options.  You can change the options
in the Import CAD File box, described later in this chapter.
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The Save and Save As Commands

  

Figure 4-4   Save Job File

This command saves your current work as a CADImport CAD Job file.  This file structure
includes the Component List and the Dot List information currently in the program.
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Import CAD File

The Import CAD File box is the main screen used for setting data conversion parameters.
This box appears when you select Import CAD File from the File menu.

Figure 4-5   The Import CAD File Box

This box allows you to select the raw CAD data file to be imported and to modify the way
the data appears onscreen.  You can set the units to be used for the XY coordinates, define
the format of the data within columns, set the data type for each column, and define rows as
comments or fiducials.  You can access various data format options, based on your selected
column type.  All of these options are discussed in detail in Section 1 – System Overview.
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Save As Fluidmove File

Figure 4-6   Export Fluidmove File

This will be the last step you perform in the CADImport job.  You should complete all the
steps as described in the Overview chapter.

You can save the job as a Fluidmove file only from Dot View mode.  CADImport formats
the Dot List information and save it in files that can be used by the Fluidmove program.

This command saves two Fluidmove files: a .FMW (for FMW) or a .FMC (for FmNT) file
and a .AVW file. Both files are required by Fluidmove to start the dispense process.
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The Print Command

Figure 4-7   Print Command

Use this option to print a copy of your Component List to your current printer.

To choose a different printer, select from the pull-down list under the printer Name field.
Click Properties to access the settings for the current printer.

You can optionally create a file on disk formatted for the current printer by enabling Print to
file.

Use Print Range to print only selected rows from the file.
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Print Setup

  

Figure 4-8   Print Setup

You can select a different printer using the Printer Name pull-down list. Click Properties to get
access to the printer settings.

The Paper Size and Source lists show all of the options available for your printer.  You may also
choose to print in Landscape or Portrait Orientation.

The Recently Used File List

This list appears at the bottom of the File menu. It shows the last three CADImport .JOB files
you opened.  To open a file from the list, click on its name.

The Exit Command

When you exit CADImport you will be prompted to save your work in a CADImport .JOB
file if you have not already done so.
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The Edit Menu

Figure 4-9   Edit Menu

The options on the Edit menu allow you to edit component properties in Component View
mode or dot properties in Dot View mode.  Refer to “The View menu” (later in this section)
for an explanation of view types.

To edit a component or dot, you must first select the component, dot, or group of
components or dots to be edited.  The Edit menu provides several selection methods, which
are described in the following pages.  Your editing options depend on the View Type you
select.

In Component View mode you can:
• Select a single component and edit its properties (such as location, rotation,

designator, library component, and part number)
• Select a group of components that correlate with a specific library component.

In Dot View you can:
• Select a single component and change its properties (such as Dot List Insertion

Order, Location or Dot Type)
• Select a group of dots and assign a Dot Type.

Select All

Select All lets you select all the components in the Component List or all the dots in the Dot
List.
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Select By Names

For component editing you will usually use Select By Names to select components.  This is the
quickest way to select a group with a common component name or part number.  This option
is only available in Component View mode and allows you to select a group of components with a
particular designator, part number or component label.  The procedure below instructs you
in using this option.

Figure 4-10   Components Selected by Part Number

To select components for editing using the Edit menu options:

1. Enter the designator, part number, or component label you want to match in the
corresponding box.

2. Click Select next to the information you entered.

> Each newly selected component or group of components is added to those you
have already selected.  For example if you click Select next to Part no (as shown
in Figure 4-10 above), all components with the part number N70-223 will be
selected.  Then, if you click Select next to Component, all components named
C1206 will be selected in addition to the first set.

> Selected components are plotted in green in the Component View window and
highlighted in the Component List.

> To clear your current selection, click Clear All.

3. Once you have selected the desired set of components, click OK.

4. Proceed to the instructions for using the Edit Selected option on the Edit menu (later in
this section) to assign CADImport library component types or change component
properties.
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To select individual components or dots for editing:

You can also select individual components from the Component View Window or the
Component List.  Refer to the chart below for commands.

To select dots instead of components, click on the Dot View button  on the toolbar (or on
View; Type; Dot) to switch to the Dot View screen, then use one of the methods described in the
table below, substituting “dot” for “component” to select the dots.

Table 4-1   Component and Dot Selection Methods

To select: From the Component List:

Single component Click on the row number of the component or double click
on it in the Component List.

Adjacent group of components
Click on the row number of the first component.  Hold
down the Shift key, and click on the row number of the last
component to select all components in between.

Non-adjacent group of
components

Hold down CTRL and click the row number of each
component.

To select: From the Component View window:

Single component Place the cursor on the component and click.

Group of components Hold down Shift and click on the components

Clear Selected

This option clears your current selection.  It functions in the same way as the Clear All button,
described above.
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Edit Selected

Once you have selected a group of components or dots using one of the methods described
above, this command allows you to edit your selection.  The available options depend on
whether you are in Component View mode or Dot View mode.  Refer to “View Types”
under “The View Menu,” later in this section for a detailed explanation of each mode.  The
editing options are described in the following pages.

Figure 4-11   Component Properties Dialogue Box – Single Component

Editing a Single Component or a Group of Components

When a CAD file is imported, some or all of the component names may not match names in
the component library.  These components are marked as unassigned.  Unassigned
components are represented in the Component View screen by gray dots and by red text in
the Component List, on the left side of the screen.  In Component View mode, the
Component Properties option (for a group or a single component) allows you to assign an
unassigned group of components to a predefined CADImport component library type.  You
can access this option by double-clicking on the image of a component in the Component
View screen or on a row of component information.  This option also allows you to reassign
a group of components you have selected and to change the properties for the group.

You may also edit the properties for a single component.  When you select a single
component, you may edit any of the properties in the Component Properties box, shown
above.  These procedures are explained in Section 3 – Importing and Formatting CAD Data.
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Editing a single dot or a group of dots:

When you select a single dot, you can edit the Insertion Order, X location, Y Location, and Dot Type.

Insertion Order refers to the sequence in which each dot is dispensed in the Fluidmove pattern.
When you change this value, you move the dot up or down in the sequence.  Note that the
View; Optimize Path option will reorder the dots to achieve the shortest path.  If you want to
place dots in a particular order you must do so after the Optimize Path step

Editing the X Location or Y Location of a dot changes the component location on the board.

The Dot Type controls the size of the dispensed dot.  Dot Types are defined as part of the
Fluidmove procedure.  Refer to the Fluidmove for Windows NT Installation and User
Guide for detailed descriptions of dot types and their associated parameters.

When you select a group of dots, you may change only the Dot Type.

  

Figure 4-12   Dot Properties Box

Delete Selected

This option removes the selected component from the Component List. Note that unassigned
components are not written to the Fluidmove file.  This option is useful for removing
unwanted components from the list.
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Add Fiducials

If you try to save a newly created CAD file that has no fiducials, CADImport prompts you
to add them. Use the Add Fiducials feature to add fiducials to files that have none. Clicking
on Add Fiducials opens the Add Fiducials dialog box shown in Figure 4-13.

Figure 4-13   Add Fiducials Box

To add fiducials to a CAD file:

1. Type the X coordinate of the fiducial in the X Location text box.

2. Type the Y coordinate of the fiducial in the Y Location text box.

3. Click OK.

> FmNT will move the dispensing head to the indicated X,Y Location. A Teach
Window opens in which you can adjust the dispensing head position, if
necessary.

4. Repeat Steps 1 through 3 for the second fiducial.
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Component Report

The Component Report dialog box (shown in ) shows a list of all of the components on the
board, the number of each component and the total number of all components on the board.
This feature is a useful way to check your CADImport data.

Figure 4-14   Component Report Box



Menu and Screen Configurations 4-15

The View Menu

Figure 4-15   View Menu

Zoom

Use this option to set the zoom factor for the View window.  You may need to zoom in to
see more detail of closely spaced components or dots.

View Type

         

This option switches between Component View and Dot View. You can also use the toolbar
buttons to switch between the two view types:

Component View   Dot View

The current view type is shown on the status line at the bottom of the screen.

Component View shows the component outlines and adhesive or solder dots. You can zoom
in to see the details of a particular dot.  The Component List is displayed at the left side of
the screen with the currently selected components highlighted.  The Component View
window shows the currently selected components in green.

Dot View shows the adhesive or solder dots and the path. Initially, the path follows the
sequence of dots in the file. Use the View, Optimize Path option to reorder the Dot List and
minimize the path length.

Component View Dot View
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Certain CADImport options are only available in a particular view mode:

Table 4-2   Component/Dot View Options

Component View only options Dot View only options

Edit; Select by names View; Optimize Path

View; Step and Repeat Board File; Save as Fluidmove file
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The Tools Menu

  

Figure 4-16   Tools Menu

Component Library

The Component Library contains approximately 300 SMD components, classified into 13
component types.  These types are listed in Appendix A.  Each library component has a
unique name and set of properties.  You can map (assign) unassigned components to a
library component and change the component properties, if necessary.  These procedures are
explained in detail in Section 3 – Importing and Formatting CAD Data.

Figure 4-17   Component Library Box
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Dispense Mode

Figure 4-18   Selecting Dispense Mode

This option specifies whether components are to be affixed with adhesive glue or solder
paste.  This setting controls the configuration of dots assigned to each component as defined
in the Component Library (see the Component Library section of this chapter for details).
The current dispense mode is shown on the status line at the bottom of the screen.

Optimize Path

Figure 4-19   Optimize Path Box

This option is only available in Dot View mode.

Initially, the dispense path is generated based on the sequence of the dots as they occur in
the original file. The Optimize Path command reorders the dots to minimize the path length for
more efficient production.

The optimizing process begins when you click on the Optimize button. The dots are reordered
in the Dot List using the nearest neighbor method to shorten the path. This does not effect
the order of the components in the Component List. When the optimization is complete,
CADImport will report the new path length and difference in path distance as shown above.

Any editing changes such as re-assigning components, changing their location, or changing
the board orientation (using mirror and rotate) will cause re-generation of the Dot List, so
you will need to re-optimize.

If you are setting up a panel with multiple boards, you should first use the Step and Repeat
Boards option to set up the panel, then use Optimize Path to shorten the path.  The Step and
Repeat Boards feature is discussed later in this section.  Note that mirroring or rotating the
boards also affect the dispensing pattern and must be completed before optimizing the path.
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Figure 4-20   Optimized Dispensing Path

?NOTE Although the dispensing head path in the optimized version
contains long moves, the long moves actually take less time to
complete than shorter moves. When executing long moves, the
dispensing head spends more time at maximum speed that it does
while executing shorter moves.

?NOTE Components with very complex dot patterns take longer to
maximize than components with simpler dot patterns.

Path After Optimization

Path Before
Optimization
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Step and Repeat Boards

This feature lets you set up multiple boards to be printed with the same pattern on a single
panel.  It is only available in Component View mode.

Figure 4-21   Step and Repeat Boards Screen

The Step and Repeat Boards feature allows you to lay out multiple boards, all with the same
dispensing pattern, on a single panel.  You can then modify the board properties of each
panel.  The features of the Step and Repeat Boards screen are discussed below.  For a
complete procedure, see “Laying Out Step and Repeat Boards” in Section 3 – Importing and
Formatting CAD Data.

The Boards (Rows x Columns) boxes allow you to indicate the number and arrangement of the
boards.

Clicking on New Panel provides you with a preview of the new panel layout with the current
boards and step distance parameters.

Board List with
Board 2 Selected

Board Properties
for Selected
Board

Panel Layout Showing
Preview of Board Size
and Arrangement
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The Units box allows you to specify the type of units used for the board size and step
distance.  While these coordinates are stored internally in mils, this option allows you to
work with any of the coordinate types.

The default Step Distance (XxY) is the same as the board’s Width and Height.  By default,
CADImport uses the minimum and maximum location values from the Component List to
calculate the board dimensions.

The value in the XStart box indicates the origin of the pattern on the second board on the
X-Axis (row) in relation to the 0,0 pattern origin of the first board.  The value in the YStart
box indicates the origin of the pattern on the next board on the Y-Axis in relation to the 0, 0
pattern origin on the first board.  These pattern origin distances are approximations only; the
area of the board displayed onscreen is 5% larger than actual size.  Therefore, it is important
to measure the actual pattern origin distances by hand if you need to know the exact figures
for programming purposes.  The distances between the dots in each pattern are, however,
accurate.

The Board # list indicates the board number, XStart, YStart and Rotation for each board on the
panel.  You can change these settings as well as the board Width and Height.  Click on Save Values
to see a preview of the new board properties in the Panel Layout window.

When you click OK, CADImport generates a new Component List by duplicating the
components on the first board as indicated by the Boards (Rows x Columns) setting. Therefore, it
is best to make all editing changes on the original (single) board before using the Step and
Repeat feature.

Once the new list has been generated you can use the board orientation buttons:

  X mirror   Y mirror   Rotation

to re-orient the entire new panel as needed.





Tutorial 5-1

5  Tutorial

Overview

This chapter contains a tutorial that highlights several of CADImport’s capabilities:
• Read in CAD data
• Map components
• Optimize path
• Save as Fluidmove file
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Read in the CAD File

To open the CAD data file:

1. From the File menu, select Import CAD File.

> The Import CAD File box appears.

Figure 5-1   Import CAD File Box (Empty)

2. Click the Get CAD File button.

  

Figure 5-2   Selecting a CAD File
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3. In the Get CAD File box, select the file sample.txt and click Open.

> The Import CAD File box now displays the data in the window.

Figure 5-3   Import CAD File Box Displaying Data

?NOTE If no data is displayed in the Import CAD File box, make sure that you have
chosen the correct XY Units in which to display the data.
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To assign a data type to each column:

1. Click on the Column 1 heading.

2. In the Set Column As list choose Designator.

> Continue with the selections in Table 5-1.

Table 5-1   Assigning Data Types

Click the heading: Select from the Set Column As: list

Column 2 X Location

Column 3 Y Location

Column 4 Rotation

Column 5 Component

> When you are finished, the Import CAD File box should look like this:

Figure 5-4   Import CAD File Box, Data Types Assigned
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To import the CAD data from the file:

1. Once these selections are completed click Import CAD Data.

Component List Component Window

Figure 5-5   Component View Screen Displaying Imported Data

> On your screen, you will see the Component List on the left side of the screen
and the Component View window showing a graphical representation of the
board and components.

> The Status Line at the bottom of the screen indicates the total number of
components (189) and the number remaining unassigned (53).  The remaining
components have been assigned to library components with names that are
identical to those imported.
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Map components

In order to assign the remaining unassigned components you will need to loop through the
following procedure twice.  Perform instructions 1 - 7 with the Step A options, then again
with the Step B options.

To select a group of components:

1. From the Edit menu, choose Select By Names.

> The Select by Names box appears.

2. In the Select By Names box, click on the following line of the file in the window.

Step Window Text

A C101   CAP_0805

B C77   CAP_1206

> For step A the screen will look like this:

  

Figure 5-6   Component Selected in Select By Names Box

3. Click the Select button next to the Component field.

> All the components with the component label shown will be selected.  The
status line under the file window indicates the number of components selected.

4. Click OK to return to the CADImport main screen.
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To assign the selected group to a library component type:

1. From the Edit menu, choose Edit Selected.

> The Component Properties box appears.

Figure 5-7   Component Properties Box, Multiple Components Selected

2. Click Browse.

> The Select Component box appears.  This box allows you to choose the library
component to which you will assign the selected group.

Figure 5-8   Selecting a Component
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Step In the Component Type
list choose

In the Component Name
list choose

A C(Capacitor). C0805.

B C(Capacitor). C1206

3. Click OK.

> All of the selected components are now assigned to the library component you
have chosen.
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Optimize path

Initially, the path that CADImport generates simply follows the order of the components in
the CAD file.  This path is random and can result in inefficient production.  The Optimize
Path command produces a new path of reduced length for more efficient production.

The current View Type is Component.  In order for you to use the Optimize Path command, the
View Type must be set to Dot.

1. From the View menu, select View Type; Dot to switch from Component View to Dot
View, or click the View Dots button.

> The CADImport main window now displays the dispense dot locations for the
components and the current (random) dispense path.

Figure 5-9   Dot View Screen Before Optimizing Path

2. From the Tools menu, select Optimize Path.

> The Optimize Path box shows the number of components and current path
length.

3. Click Optimize.

> CADImport regenerates the path and displays the optimized path statistics in
the Optimize Path box.
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Figure 5-10   Optimized Path Information

4. Click Done.

> The shortened path appears in the Dot view window.

Figure 5-11   Dot View Screen After Optimizing Path
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Save as Fluidmove file

Once all the components are mapped and the path has been optimized you are ready to save
the CAD data as Fluidmove files. Two files are saved: a header file and a data file.

To save the CADImport data as a Fluidmove job:

1. From the File menu, select Save As Fluidmove File.

> The Export Fluidmove File box appears.

 

Figure 5-12   Saving As a Fluidmove File

2. In the File name entry field enter the name you want to use for the files without an
extension, for example:  mytest.

> CADImport saves two files: mytest.AVW and mytest.FMW.
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Appendix - Library Components
The following table contains a complete list of the components available in the
Asymtek.lib file provided with the CADImport program.

CAPACITOR

AE4 ALUMINIUM ELECTROLYTIC CAPACITORS, United Chemi-Con
AE5 ALUMINIUM ELECTROLYTIC CAPACITORS, United Chemi-Con
AE6.3 ALUMINIUM ELECTROLYTIC CAPACITORS, United Chemi-Con
B6 ALUMINIUM ELECTROLYTIC CAPACITORS, United Chemi-Con
C0402 0402, CHIP CAPACITOR
C0504 0504, CHIP CAPACITOR
C0603 0603, CHIP CAPACITOR
C0805 0805, CHIP CAPACITOR
C0805MIL 0805, CHIP CAPACITOR, FOR MILITARY USE
C1005 1005, CHIP CAPACITOR
C1005MET 1005, CHIP CAPACITOR,Metric
C1005MIL 1005, CHIP CAPACITOR, FOR MILITARY USE
C1206 1206, CHIP CAPACITOR
C1206MIL 1206, CHIP CAPACITOR, FOR MILITARY USE
C1206WS 1206, CHIP CAPACITOR, optimized for wave solder use to prevent cracking
C1210 1210, CHIP CAPACITOR
C1210MIL 1210, CHIP CAPACITOR, FOR MILITARY USE
C1210WS 1210, CHIP RESISTOR, optimized for wave solder use to prevent cracking
C1310 1310, CHIP CAPACITOR, Metric
C1608 1608, CHIP CAPACITOR, Metric
C1805 1805, CHIP CAPACITOR
C1808 1808, CHIP CAPACITOR
C1808MIL 1808, CHIP CAPACITOR, FOR MILITARY USE
C1812 1812, CHIP CAPACITOR
C1218MIL 1812, CHIP CAPACITOR, FOR MILITARY USE
C1825 1825, CHIP CAPACITOR
C2012 2012, CHIP CAPACITOR, Metric
C2220 2220, CHIP CAPACITOR
C2225 2225, CHIP CAPACITOR
C3216 3216, CHIP CAPACITOR, Metric
C3225 3225, CHIP CAPACITOR, Metric
C4532 4532, CHIP CAPACITOR, Metric
C4564 4564, CHIP CAPACITOR, Metric
C6 ALUMINIUM ELECTROLYTIC CAPACITORS, United Chemi-Con
CMLL34 MELF, MLL34, CAPACITOR
CMLL41 MELF, MLL41, CAPACITOR
D6 ALUMINIUM ELECTROLYTIC CAPACITORS, United Chemi-Con
D8 ALUMINIUM ELECTROLYTIC CAPACITORS, United Chemi-Con
ELECTAA ELECTROLYTIC, CASE SIZE AA, MEPCO/CENTRALLAB
ELECTBB ELECTROLYTIC, CASE SIZE BB, MEPCO/CENTRALLAB
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CONNECTOR

BERG2-1 CONNECTOR, Single Row, 2-50 Pins, BERG
BERG2-8 CONNECTOR, Double Row, 2-50 Pins, BERG
BERG3-8 CONNECTOR, Double Row, Side Entry, 3-52 Terminators per row , BERG
BERG4-8 CONNECTOR, Double Row, Side Entry, 2 Rows, 12-65 Terminators per row
ITT9 DB9 CONNECTOR, ITT CANNON
METH1-8 CONNECTOR, Double Row, 2-50 Pins, METHODE
METH2-8 HEADER, Dual Row, Vertical Entry, 2-40 Pins per row, METHODE
MOLEX1-8 CONNECTOR, Double Row, 2-150 Pins, MOLEX
MOLEX2-8 CONNECTOR, Double Row, Side Entry, 2-40 Rows, 4-80 Contacts, MOLEX
MOLEX3-8 HEADER, Double Row, Vertical Entry, MOLEX
SAM1-8 CONNECTOR, Double Row, 2-65 Leads per row, SAMTECH
SAM2-4 CONNECTOR, Single Staggered, 2-65 Leads, SAMTECH
SAM3-4 HEADER, Dual Row Staggered, 2-39 Leads, SAMTECH
SAM4-4 HEADER, Single Row, Horizontal Entry, 2-39 Pins, SAMTECH
SAM5-8 HEADER, Dual Row, Horizontal Entry, 2-39 Pins per row, SAMTECH
SAM6-8 HEADER, Dual Row, Vertical Entry, 2-39 Pins per row, SAMTECH
TEKA1-8 CONNECTOR, Double Row, 2-50 Pins, TEKA

CRYSTALS

FCX-1 CRYSTAL, FOX
OSCDIP CRYSTAL, SO Package with C style Leads
SOC-1 CRYSTAL, SO Package with C style Leads
DIODE
DPAK1 DPAK STYLE, VERSION 1
DPAK2 DPAK STYLE, VERSION 2
DPAK3 DPAK STYLE, VERSION 3
SOT-D DIODE, SOT PACK, TOSHIBA
SOT-T DIODE, TWO TERMINAL GULLWING, ITT

IC-PF (CFP,PFP,QFP)

BPFP100 PFP100, PLASTIC BUMP QUAD FLAT PACKAGE
BPFP132 PFP132, PLASTIC BUMP QUAD FLAT PACKAGE
BPFP164 PFP164, PLASTIC BUMP QUAD FLAT PACKAGE
BPFP196 PFP196, PLASTIC BUMP QUAD FLAT PACKAGE
BPFP244 PFP244, PLASTIC BUMP QUAD FLAT PACKAGE
BPFP84 PFP84, PLASTIC BUMP QUAD FLAT PACKAGE
CFP10-03 10 Lead Ceramic Flat Pack Type MO-003
CFP10-04 10 Lead Ceramic Flat Pack Type MO-004
CFP14-03 14 Lead Ceramic Flat Pack Type MO-003
CFP14-04 14 Lead Ceramic Flat Pack Type MO-004
CFP16-04 16 Lead Ceramic Flat Pack Type MO-004
CFP16-21 16 Lead Ceramic Flat Pack Type MO-021
CFP20-22 20 Lead Ceramic Flat Pack Type MO-022
CFP24 24 PIN CERPACK
CFP24-19 24 Lead Ceramic Flat Pack Type MO-019
CFP24-21 24 Lead Ceramic Flat Pack Type MO-021
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IC-PF (CFP,PFP,QFP)   continued

CFP28 28 PIN CERPACK
CFP28-19 28 Lead Ceramic Flat Pack Type MO-019
CFP36-20 36 Lead Ceramic Flat Pack Type MO-020
CFP36-21 36 Lead Ceramic Flat Pack Type MO-021
CFP36-23 36 Lead Ceramic Flat Pack Type MO-023
CFP40-18 40 Lead Ceramic Flat Pack Type MO-018
CFP40-20 40 Lead Ceramic Flat Pack Type MO-020
CFP42 42 PIN CERPACK
PFP16 16 PIN FLAT PACK
PFP18 18 PIN FLAT PACK
PFP20 20 PIN FLAT PACK
PFP28 28 PIN FLAT PACK
QFP100-1 QFP 100, 16.4 x 28.6 mm, 20x30 Lead Package
QFP100-2 QFP 100, 14.0 x 20.0 mm Body, 20x30 Lead Package
QFP120 QFP 120, 32.0 x 32.0 mm, 30x30 Lead Package
QFP128 QFP 128, 28.0 x 28.0 mm Body, 32x32 Lead Package
QFP136 QFP 136, 28.0 x 28.0 mm Body, 34x34 Lead Package
QFP144 QFP 144, 28.0 x 28.0 mm Body, 36x36 Lead Package
QFP160 QFP 160, 28.0 x 28.0 mm Body, 40x40 Lead Package
QFP196 QFP 196, 32.5 x 32.5 mm Body, 49x49 Lead Package
QFP208 QFP 208, 32.258 x 32.5 mm Body, 52x52 Lead Package
QFP44-1 QFP 44, 13.5 x 14.5 mm, 11x11 Lead Package
QFP44-2 QFP 44, 12.3 x 12.3 mm, 11x11 Lead Package
QFP44-3 QFP 44, 14.4 x 14.4 mm, 11x11 Lead Package
QFP48 QFP 48, 17.3 x 17.3 mm, 12x12 Lead Package
QFP52 QFP 52, 21.3 x 21.3 mm, 13x13 Lead Package
QFP54 QFP 54, 14.4 x 14.4 mm, 13x14 Lead Package
QFP56-1 QFP 56, 13.5 x 14.5 mm, 14x14 Lead Package
QFP56-2 QFP 56, 24.0 x 20.0 mm, 14x14 Lead Package
QFP60 QFP 60, 24.0 x 20.0 mm, 14x16 Lead Package
QFP64-1 QFP 64, 17.6 x 17.6 mm, 16x16 Lead Package
QFP64-2 QFP 64, 17.6 x 17.6 mm, 13x19 Lead Package
QFP64-3 QFP 64, 18.4 x 18.4 mm, 16x16 Lead Package
QFP64-4 QFP 64, 18.7 x 24.7 mm, 13x19 Lead Package
QFP64-5 QFP 64, 22.8 x 22.8 mm, 16x16 Lead Package
QFP70 QFP 70, 16.4 x 28.6 mm, 11x24 Lead Package
QFP74 QFP 74, 23.2 x 23.2 mm, 18x19 Lead Package
QFP80-1 QFP 80, 14.0 x 14.0 mm Body, 20x20 Lead Package
QFP80-2 QFP 80, 16.0 x 20.0 mm Body, 16x24 Lead Package
QFP80-3 QFP 80, 14.0 x 20.0 mm Body, 16x24 Lead Package
QFP80-4 QFP 80, 16.4 x 28.6 mm, 16x24 Lead Package
QFP88 QFP 88, 14.0 x 20.0 mm Body, 18x26 Lead Package
QFP94 QFP 94, 23.2 x 23.2 mm, 23x24 Lead Package
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IC-LCC (LCC,PLCC,JLCC)

LCC16 16 PIN RECTANGULAR Leadless Chip Carrier
LCC18 18 PIN RECTANGULAR Leadless Chip Carrier MIL-M-38510 C-10A
LCC18ECA 18 PIN RECTANGULAR Leadless Chip Carrier JEDEC ECA Package
LCC18ECB 18 PIN RECTANGULAR Leadless Chip Carrier JEDEC ECB Package
LCC20 18 PIN RECTANGULAR Leadless Chip Carrier MIL-M-38510 C-13
LCC20ECD 20 PIN Leadless Chip Carrier JEDEC ECD Package
LCC22 22 PIN Leadless Chip Carrier JEDEC ECE Package
LCC24 24 PIN RECTANGULAR Chip Carrier
LCC24SQ 24 PIN SQUARE Chip Carrier
LCC28 28 PIN SQUARE Leadless Chip Carrier MIL-M-38510 C-11A
LCC28 28 PIN SQUARE Leadless Chip Carrier MIL-M-38510 C-4
LCC32 32 PIN RECTANGULAR Leadless Chip Carrier MIL-M-38510 C-12
LCC44SQ 44 PIN SQUARE Leadless Chip Carrier MIL-M-38510 C-5
LCC52SQ 52 PIN SQUARE Leadless Chip Carrier
LCC68SQ 68 PIN SQUARE Leadless Chip Carrier
LCC80 80 PIN RECTANGULAR Leadless Chip Carrier
LCC80SQ 80 PIN SQUARE Leadless Chip Carrier
LCC94 94 PIN SQUARE Leadless Chip Carrier
LCCC68 68 PIN J LEADED CERDIP CARRIER, 17x17 Leads
LCCC84 84 PIN J LEADED CERDIP CARRIER, 21x21 Leads
LCCSQ 18 PIN SQUARE Leadless Chip Carrier MIL-M-38510 C-2A
PLCC100 PLCC100, SQUARE, 25x25 Lead Package
PLCC128 PLCC128, SQUARE, 32x32 Lead Package
PLCC18 PLCC18, RECTANGULAR, 4x5 Lead Package
PLCC18L PLCC18L, RECTANGULAR, 4x5 Lead Package
PLCC20SQ PLCC20, SQUARE, 5x5 Lead Package
PLCC22R PLCC22, RECTANGULAR, 4x7 Lead Package
PLCC28R PLCC28, RECTANGULAR, 5x9 Lead Package
PLCC28SQ PLCC28, SQUARE, 7x7 Lead Package
PLCC32R PLCC32, RECTANGULAR, 7x9 Lead Package
PLCC44 PLCC44, SQUARE, 11x11 Lead Package
PLCC52 PLCC52, SQUARE, 13x13 Lead Package
PLCC68 PLCC68, SQUARE, 17x17 Lead Package
PLCC84 PLCC84, SQUARE, 21x21 Lead Package
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IC-SO (SO,SOP,SOJ,VSO)

SO14M1 SO14, PLASTIC MINIFLAT PACKAGE VERSION 1
SO14M2 SO14, PLASTIC MINIFLAT PACKAGE VERSION 2
SO14MB SO14, MEDIUM BODY, RESISTOR PACK, DALE
SO14NB SO14, NARROW BODY
SO14WB SO14L, WIDE BODY
SO16M1 SO16, MINIFLAT PACKAGE
SO16MB SO16, MEDIUM BODY, RESISTOR PACK, DALE
SO16NB SO16, NARROW BODY
SO16WB SO16L, WIDE BODY
SO18WB SO18, WIDE BODY
SO20M1 SO20, MINIFLAT PACKAGE VERSION 1
SO20M2 SO20L, WIDE BODY
SO20M3 SO20, MINIFLAT PACKAGE VERSION 3
SO24M1 SO24, MINIFLAT PACKAGE VERSION 1
SO24M2 SO24, MINIFLAT PACKAGE VERSION 2
SO24M3 SO24, MINIFLAT PACKAGE VERSION 3
SO24U SO24, UNIVERSAL SRAM, used for Hitachi, SMOS & Toshiba SRAMs
SO24WB SO24, WIDE BODY
SO28M1 SO28, MINIFLAT PACKAGE VERSION 1
SO28M2 SO28, MINIFLAT PACKAGE VERSION 2
SO28M3 SO28, MINIFLAT PACKAGE VERSION 3
SO28U SO28, UNIVERSAL SRAM, used for Hitachi, SMOS & Toshiba SRAMs
SO28WB SO28, WIDE BODY
SO32M1 SO31, MINIFLAT PACKAGE
SO40M1 SO40, MINIFLAT PACKAGE
SO4M1 SO4, METRIC BODY
SO6M1 SO6, METRIC BODY
SO8M1 SO8, METRIC BODY, VERSION 1
SO8M2 SO8, METRIC BODY, VERSION 2
SO8NB SO8, NARROW BODY
SO8NBWS SO8, NARROW BODY, optimized for wave solder use to prevent cracking
SO8WB SO8L, WIDE BODY
SOJ14 SOJ14, PIN PLASTIC
SOJ16 SOJ16, PIN PLASTIC
SOJ18 SOJ18, PIN PLASTIC
SOJ20 SOJ20, PIN PLASTIC
SOJ20LM SOJ20, LEAD MOLDED
SOJ22 SOJ22, PIN PLASTIC
SOJ24 SOJ24, PIN PLASTIC
SOJ24LM SOJ24, LEAD MOLDED
SOJ26 SOJ26/20 PIN PLASTIC
SOJ28 SOJ28, PIN PLASTIC
SOJ28LM SOJ28, LEAD MOLDED
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IC-SO (SO,SOP,SOJ,VSO)  continued

SOP24 SOP24, PLASTIC FP
SOP28 SOP28, PLASTIC FP
SOP32 SOP32, PLASTIC FP
VSO40 40 Lead Plastic VSO Package
VSO56 56 Lead Plastic VSO Package

IND(Inductor)

DIMLL34 MELF, MLL34, DIODE
DIMLL41 MELF, MLL41, DIODE
IND1 INDUCTOR, Coilcraft, VERSION 1
IND2 INDUCTOR, Coilcraft, VERSION 2
IND3 INDUCTOR, Vanguard, VERSION 1
IND4 INDUCTOR, Vanguard, VERSION 2
IND5 INDUCTOR, SFE, VERSION 1
IND6 INDUCTOR, Coilcraft, VERSION 3
IND7 INDUCTOR, SFE, VERSION 2
IND8 INDUCTOR, SFE, VERSION 3
IND9 INDUCTOR, Murata Erie, VERSION 1
IND-DEL0820 INDUCTOR, DELEVAN, DEL0820
IND-DEL103 INDUCTOR, DELEVAN, DEL103
IND-DEL1331 INDUCTOR, DELEVAN, DEL1331
IND-NL1210 INDUCTOR, TDK, NL1210
IND-NL1812 INDUCTOR, TDK, NL1812
IND-NL2216 INDUCTOR, TDK, NL2216
SOD-80 MELF, SOD-80, DIODE
SOD-87 MELF, SOD-87, DIODE

R(Resistor)

MELF1 MELF COMPONENT, Panasonic
MELF2 MELF COMPONENT, Taiyo Yuden
MLL34 MELF, MLL34 DIODE, RESISTOR OR CAPACITOR
MLL41 MELF, MLL41 DIODE, RESISTOR OR CAPACITOR
R0402 0402, CHIP RESISTOR
R0603 0603, CHIP RESISTOR
R0805 0805, CHIP RESISTOR
R0805MIL 0805, CHIP RESISTOR, FOR MILITARY USE
R1005 1005, CHIP RESISTOR, Metric
R1055MIL 1005, CHIP RESISTOR, FOR MILITARY USE
R1206 1206, CHIP RESISTOR
R1206MIL 1206, CHIP RESISTOR, FOR MILITARY USE
R1206WS 1206, CHIP RESISTOR, optimized for wave solder use to prevent cracking
R1210 1210, CHIP RESISTOR
R1210MIL 1210, CHIP RESISTOR, FOR MILITARY USE
R1210WS 1210, CHIP RESISTOR, optimized for wave solder use to prevent cracking
R1406 1406, MELF DIODE, RESISTOR OR CAPACITOR
R1505MIL 1505, CHIP RESISTOR, FOR MILITARY USE
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R(Resistor)  continued

R1510MIL 1510, CHIP RESISTOR, FOR MILITARY USE
R1608 1608, CHIP RESISTOR, Metric
R1706MIL 1706, CHIP RESISTOR, FOR MILITARY USE
R2010 2010, CHIP RESISTOR
R2010MIL 2010, CHIP RESISTOR, FOR MILITARY USE
R2012 2012, CHIP RESISTOR,  Metric
R2309 2309, MELF DIODE, RESISTOR OR CAPACITOR
R2512 2512, CHIP RESISTOR
R3216 3216, CHIP RESISTOR, Metric
R3225 3225, CHIP RESISTOR, Metric
R3516 3516, CHIP RESISTOR, Metric
R5025 5025, CHIP RESISTOR, Metric
R5923 5923, CHIP RESISTOR, Metric
R6332 6332, CHIP RESISTOR, Metric
RMLL34 MELF, MLL34, RESISTOR
RMLL41 MELF, MLL41, RESISTOR

SW (Sockets,Switches)

Socket28 SOCKET, SQUARE, 28 Position, 7x7 Leads, METHODE
Socket32 SOCKET, RECTANGLE, 32 Position, 9x7 Leads, METHODE
Socket44 SOCKET, SQUARE, 44 Position, 11x11 Leads, METHODE
Socket52 SOCKET, SQUARE, 52 Position, 13x13 Leads, METHODE
Socket68 SOCKET, SQUARE, 68 Position, 17x17 Leads, METHODE
Socket84 SOCKET, SQUARE, 84 Position, 21x21 Leads, METHODE

T (Tantalum)

T3216 TANTALUM, A CASE SIZE, 3216
T3518 TANTALUM, EXTENDED RANGE, 3518
T3527 TANTALUM, EXTENDED RANGE, 3527
T3528 TANTALUM, B CASE SIZE, 3528
T6032 TANTALUM, C CASE SIZE, 6032
T7227 TANTALUM, EXTENDED RANGE, 7227
T7243 TANTALUM, D CASE SIZE, 7243
T7257 TANTALUM, EXTENDED RANGE, 7257
T7343 TANTALUM,   CASE SIZE, 7343, IPC
TNEC-B TANTALUM, NEC B CASE SIZE
TNEC-C TANTALUM, NEC C CASE SIZE
TNEC-D TANTALUM, NEC D CASE SIZE

TC(Trimmer Condenser)

TRIM1 TRIMMER, TWO LEADED ADJUSTABLE, SPRAGUE
TRIM10 TRIMMER, THREE LEADED ADJUSTABLE, Bourns
TRIM11 TRIMMER, THREE LEADED ADJUSTABLE, Bourns
TRIM2 TRIMMER, TWO LEADED ADJUSTABLE, SPRAGUE
TRIM3 TRIMMER, TWO LEADED ADJUSTABLE, SPRAGUE
TRIM4 TRIMMER, TWO LEADED ADJUSTABLE, SPRAGUE
TRIM5 TRIMMER, TWO LEADED ADJUSTABLE, SPRAGUE
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TC(Trimmer Condenser)  continued

TRIM6 TRIMMER, THREE LEADED ADJUSTABLE, VRN
TRIM7 TRIMMER, THREE LEADED ADJUSTABLE, Murata Erie
TRIM8 TRIMMER, THREE LEADED ADJUSTABLE, Murata Erie
TRIM9 TRIMMER, THREE LEADED ADJUSTABLE, Kyocera

TR(Transistor)

PD4P ECI Component
SOT143 SOT143, PHILIPS
SOT223 SOT223
SOT23 SOT23, JEDEC Package TO-236AA, Motorola
SOT23M1 SOT23, Metric, NEC
SOT23M2 SOT23, Metric, Rohm
SOT23WS SOT23, JEDEC Package TO-236AA, for wave solder to prevent cracking
SOT25 SOT25, Rohm
SOT89 SOT89
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.ASC files, 2-2
.AVW files, 2-2, 2-8, 4-5
.FMC files, 2-2
.FMW files, 2-2, 3-21, 4-5
.JOB files, 2-2, 3-21
.TXT files, 2-2

–A–
adding fiducials, 4-13
adhesive glue

selecting dispense mode, 4-18
assigning data types, 5-4

–B–
board

double sided in CAD file, 3-14
rotation, 2-8
rotation and flipping, 1-11

board layout
coordinate system, 2-3
rotating, 4-21

board rotation buttons, 1-10
boards

laying out multiple, 1-15
buttons, 1-10

–C–
CAD data

formatting, 3-1
CAD file

components on both sides of board, 3-14
importing, 2-1, 5-5
reading, 2-2

CADImport coordinate system, 2-3
Clear Selected command, 4-10
column format

delimited, 1-3
delimited column, 3-7
fixed, 1-3

column formats
fixed, 3-7

columns
formatting, 1-3, 3-7
setting delimiters, 3-9

commands
Clear Selected, 4-10
Delete Selected, 4-12
Dispense Mode, 4-18
Edit Selected, 4-11
Exit, 4-7
Import CAD File, 4-4
New File, 4-1

Optimize Path, 2-7, 4-18
Print, 4-6
Save, 4-3
Save As, 4-3
Save As Fluidmove File, 4-5, 5-11
Select All, 4-8
Select By Names, 4-9
Step and Repeat Boards, 4-20
View Type, 4-15
Zoom, 4-15

comments
in data file, 3-16
inserting, 3-20
inserting], 1-5

component
assigning to library, 2-4
coordinates, 1-8
creating new, 2-5, 3-27
deleting from library, 3-28
editing, 4-10
editing by part number, 4-9
editing group, 4-11
editing properties, 2-5
land pattern, 3-26
library, 2-4
location, 1-8
mapping, 1-8, 2-4, 3-22, 5-6
selection for editing, 3-3
types, 2-4, 4-17
unassigned, 1-12, 3-22
unmapped, 1-14

component designator, 1-8
component library, 1-1
Component Library, 1-6, 1-8, 1-13, 4-17

box, 3-29
Component List, 1-7, 1-8, 1-15

creating file, 4-6
for Step and Repeat boards, 2-6
printing, 4-6

component name, 1-8
Component Name List, 3-24
component properties, 2-4

modifying, 3-25
saving changes, 3-27

Component Properties box, 3-3, 3-22
Component Type List, 3-24
Component View mode, 2-4, 4-8, 4-15
Component View screen, 1-7, 2-3
components

selection for editing, 1-13
unmapped, 1-8

conversion process, 1-6
coordinate system, 2-3
coordinate values, 1-8
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–D–
data

editing within rows, 3-20
missing or inconsistent, 3-12

data format options, 3-8, 3-9
for both data formats, 3-13

Data Format Options box, 3-8
Data Format Options command

for Fixed Format files, 3-11
data formats, 1-3
data import, 2-1
data origin, 2-3
data types, 1-8, 3-19

assigning, 1-4, 3-19, 5-4
available, 3-19
optional, 1-4
typical, 1-4
unassigned, 3-12, 3-13

Delete Selected command, 4-12
deleting components, 3-28
delimited column data format, 1-3, 3-19
delimiters

setting, 3-9
designators

for Fixed Format files, 3-11
dispense mode, 2-4
Dispense Mode command, 4-18
dispensing

back side of board, 1-11
pattern, 1-12

dispensing path
optimizing for shortest distance, 1-12, 2-7

dot
pattern, 1-12

dot configuration
on components, 4-18

dot editing, 3-5, 4-10
Dot List, 4-18
group, 4-12
insertion order, 4-12
locations, 2-4, 2-5, 3-29
type, 4-12

dot list, 1-12
Dot List

changes to, 4-18
for optimized path, 2-8

Dot Locations list, 3-29
Dot View mode, 4-8, 4-15
Dot View screen, 1-12, 2-3, 3-4
dots

inserting and deleting, 3-30
double sided board, 3-14

–E–
Edit menu, 4-8
Edit Selected command, 4-11
editing

component group, 4-11
dot group, 4-12
dot insertion order, 4-12
dot type, 4-12

dots, 3-5, 4-10
single component, 4-11
X Location, 4-12
Y Location, 4-12

editing components, 4-10
by part number, 4-9

editing dot locations, 3-29
editing pattern, 3-5
editing text, 3-20
End Col field, 3-11
Exit command, 4-7
extraneous data, 3-16

–F–
features, 1-1
fiducial locations, 1-5

setting, 3-20
fiducials

adding, 4-13
file conversion, 1-6
File menu, 4-1
file types, 2-2
files

opening, 4-2
selecting and opening, 1-3

fixed data format, 1-3
Fixed Format

preset column headings, 3-12
Fixed Format files, 3-11
Fluidmove file

creating, 2-1, 2-8

–G–
Get CAD File command, 1-3

–I–
Ignore all problem lines option, 3-13
Ignore All Problem Lines option, 1-6
Import CAD Data button, 1-5, 1-7, 3-2
Import CAD File box, 2-3, 3-1, 4-2, 4-4

options, 1-2
Import CAD File command, 4-4
importing CAD data, 1-6, 2-1, 5-5

into FMW, 3-5
Insertion Order (dot)

editing, 4-12
installing software, 1-1

–J–
job file, 4-3, 4-7

–L–
level format option, 3-13
level selection option, 3-13
library components, 1-8, 1-13, 2-4, 3-22

associated dispensing patterns, 1-13
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–M–
mapping components, 1-8, 1-13, 3-22, 5-6
menus

Edit, 4-8
File, 4-1
Tools, 4-17
View, 4-15

missing data, 3-12
multiple boards

laying out, 2-6, 4-18, 4-20

–N–
New File command, 4-1

–O–
opening a file, 4-2
Optimize Path command, 2-7, 3-4, 4-18
optimizing dispensing path, 1-12, 2-7, 5-9
options, 1-1

–P–
part number, 1-8
pattern, 1-12

editing, 3-5
pattern origin, 1-7

for Step and Repeat boards, 2-6
Print command, 4-6
Print setup, 4-7

–R–
reading CAD data file, 2-2
Recently Used File list, 4-7
rotation, 1-8
rotation buttons, 1-10
Rotation field, 3-22
rows

available definitions, 3-20
marking, 1-5, 3-20

–S–
Save As Fluidmove File command, 4-5, 5-11
Save commands, 4-3
Save Component box, 3-27
Select All command, 4-8
Select By Names command, 4-9
Select Component box, 3-3
selecting components, 1-13
Set Column As, 3-9
Set Column As command, 1-4, 3-9, 3-19
Set Row As command, 1-5, 3-20
software installation, 1-1

solder paste
selecting dispense mode, 4-18

Start Col field, 3-11
Status Line, 1-9
Step and Repeat Boards, 1-15, 2-6, 4-18, 4-20

laying out, 3-31
system overview, 1-1

–T–
toolbar buttons, 1-10
Tools menu, 4-17
tutorial, 5-1
two-sided board, 3-14

–U–
unassigned components, 1-12, 3-22
unassigned data types, 3-12, 3-13
units

specifying type, 2-3, 3-2
unmapped components, 1-14

–V–
view buttons, 1-10
View menu, 4-15
view type, 4-10
View Type command, 4-15
view window

size and shape, 2-3

–X–
X location

field, 3-22
X Location

editing, 4-12
XY location

editing, 1-8
XY units, 3-2

specifying type, 2-3
XY Units

specifying type, 1-5
XY values

minimum and maximum, 2-3, 2-6

–Y–
Y location

field, 3-22
Y Location

editing, 4-12

–Z–
Zoom command, 4-15
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